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1 Introduction 

1.1 What is SimFlex CS? 

The SimFlex IEC 61850 Client Simulator Edition 2 is a simulator for the testing of IEC 61850 based 

servers (IEDs) that implement the Edition 2 version of the IEC 61850 standard. This software tool is 

designed for performing IEC 61850 tests including Conformance Tests. The main features of the 

Client Simulator include: 

• Script based for flexibility and expansion of the test system 

• Graphical User Interface 

• Automatic execution of scripts 

• Report & Storage of test results 

The SimFlex IEC 61850 Client Simulator is an easy to use tool with advanced capabilities that enables 

utilities, manufacturers, system integrators and conformance test laboratories to automatically test 

IEC 61850 based server devices. 

The SimFlex IEC 61850 Client Simulator comes with an extensive test suite that implements the IEC 

61850 test cases that can be individually selected and executed. The SimFlexTM IEC 61850 Client 

Simulator enables users to create new and combine existing test cases to perform complex test 

scenarios. The simulator is easy to use and its intuitive user interface enables to quickly perform 

tests. 

This makes the SimFlexTM IEC 61850 Client Simulator an excellent software solution for the electrical 

power industry. 

1.2 Benefits 

The main benefits of using the SimFlex Client Simulator are: 

• Fast and flexible automated testing of system and IED behaviour 

• Verification of IEC 61850 implementations 

• Easy setup of a conformance test laboratory 

• Generation and capturing of standard network traffic that can be stored in files 

1.3 Applications 

The SimFlexTM IEC 61850 Client Simulator has a wide range of applications.  

• IEC 61850 Edition 2 conformance testing 

• Functional testing of IEDs and systems 

• IED product development 

• GOOSE publishing 

• Network traffic generation 

• Preparation for UCA© International Users Group based IED certification 
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1.4 Key Features 

The SimFlexTM IEC 61850 Client Simulator is designed to be a versatile simulator for IEC 61850 devices 

and systems. Key features of the SimFlexTM IEC 61850 Client Simulator include:  

• Performs the test cases from the UCA© International Users Group detailed test procedures, 
based on IEC61850-10 Edition 2 

• Supported services of Basic Exchange, DataSet, Reporting, GOOSE, Logging, Tracking, 
Settings, Time synchronization … 

• Executes the UCA International Users Group detailed test procedures based on IEC 61850-10 
standard 

• Tool can be incorporated in a complex testing environment (console call) 
• Easy control of testing environment (ethernet switches, time servers, power supplies, 
secondary injection test sets etc. …),  
• Design and execute any test case through a flexible interface 
• Logging of test progress and test results in human-readable format 
• Capture network traffic on two network cards in parallel (recorded in PCAP format) that can 

be read by network analysis tools such as Wireshark 
• Advanced GOOSE engine enables publishing of GOOSE messages, including faulty messages 

for negative testing 
• Enhanced test case editor with syntax highlighting 
• Visual representation and interaction with server's data models 

The SimFlexTM IEC 61850 Client Simulator provides a flexible user interface for IEC 61850 testing. 

Many of the features of the program are available through an intuitive tool bar. 

1.5 Test Sessions 

Testing of IEDs and systems requires that test results can be stored orderly. Especially for IEC 61850 

Conformance Test Laboratories it is important that test information and results are kept together 

and stored safely. The SimFlexTM IEC 61850 Client Simulator provides Test Sessions that enable the 

user to create a specific environment for the device or system under test where all necessary 

information and test results are stored. This makes it possible to organize the results and easily 

analyze test results at a later stage. 

1.6 Test Suite 

The core of the simulator is an engine that executes predefined and user defined test definitions. 

These definitions are located in groups that, together, form a test suite. The test suite is represented 

as a hierarchical tree. 

The test suite view offers functionality to add, rename and delete groups and test scripts. Each group 

and test script can be enabled separately, which makes it possible to execute any combination of 

groups and test scripts. 

To facilitate its use the SimFlexTM IEC 61850 Client Simulator comes with a complete test suite that 

implements the UCA© International Users Group detailed test procedures for server devices. 

1.7 Script Edition 

The SimFlexTM IEC 61850 Client Simulator has a built-in editor for creating the test definitions to be 

executed. The interface provides many of the defined services in IEC 61850-7-2 to be called from 

within the test sequence. The response from the called services can be checked and the flow of the 
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test scripts can be logged in the Logging View. With a simple command the user can start and stop 

network capturing on two separate network interfaces in parallel and store the captured 

communication in a PCAP file format. It is also possible to define and show message boxes when 

user-input is required in the script. 

1.8 Logging 

In this view the user can follow the execution of the scripts. Log messages from the test sequence as 

well as messages from the test engine are shown. 

The SimFlexTM IEC 61850 Client Simulator automatically shows the response and retuned values of 

called IEC 61850 services. This makes it very easy for the user to monitor test execution. 

1.9 Basic skill requirements 

There are some main things that the user must be familiarized beforehand, in order to use this 

application. 

1.9.1 IEC 61850 standard, tissues and UCA testing. 

The user/tester of this application must have at least basic level of understanding of IEC 61850 

standards. 

This is important because the tester will use it to test the device, diagnose and analyze the result. 

The user must correctly identify that each of the network communication between the server/device 

and the client is exactly the way it should be, given the scope within the IEC 61850 standards. 

1.9.2 Python/Programming 

The user/tester must at least understand how to do basic programming. It will be better if the 

user/tester is already familiar with Python programming. The SimFlexTM IEC 61850 Client Simulator 

uses Python as the programming language for the test cases because it is a high-level programming 

language, easily understandable and configurable. 
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2 SimFlex CS overview 

2.1 Details in the main screen 

The main window has different parts: the menu bar (1), the toolbar (2), the test suite panel (3), the 

script panel (4), the device panel (5) and the log/issues panel (6). 

 

 

Figure 2-1 Main Screen 

2.2 Configuring the SimFlex CS settings 

In order to configure application settings: 

1) In the menu bar click in Edit →Settings 

 

Figure 2-2 Settings from Menu Bar 
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2) Or, in the toolbar, hover above the icon that will says "show settings" and click the icon. 

 

Figure 2-3 Settings from Tool Bar 

New window will show up. The window consists of four tabs. 

2.3 Detailed information of Settings dialog, General tab 

In the Settings dialog, General tab, you can specify program specific settings. 

 

Figure 2-4 Settings > General 

Capture interface 1 Select Primary Network Interface Card that will capture the 

network traffic during the execution of test cases 

Capture interface 2 Select Secondary Network Interface Card that will capture 

the network traffic during the execution of test cases 
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Application base directory Select the directory that will be the base for the storage of all 

program related and created files. This includes amongst 

others the network capture files, the log files, the defined 

DUTs and all session related files. 

Test-Bench name Specify the name of the test bench. The test bench is the 

system on which the SimFlexTM IEC 61850 Client Simulator 

has been installed on. 

Show test result summary Select Yes when a summary of the tests needs to be shown 

on the screen after a test run. 

Always overwrite session file Select Yes when the session file should be overwritten. This 

setting is only applicable when running test cases during a 

session. 

Continue on Assert Select Yes if user need for testing script to continue until the 

end even though Failure is detected. It is helpful, when 

complete overview of test script results is needed. 

Data Model Read Level Selection between LN, FC, DO i.e. level of DUT data model 

readout will be stopped on selected level. 

Use Analyzer Select Yes when SimFlex™ Protocol Analyzer actually is to be 

run when Analyze() is called in the script. 

Analyzer countdown Set the time the form that displays the issues found by 

SimFlex™ Protocol Analyzer has to be shown (in seconds). 

2.4 Detailed information of Settings dialog, Devices tab 

In the Settings dialog, Devices tab, you can define the Devices Under Test (DUT). On the left side of 

the dialog a list of defined DUTs is shown. Selecting a DUT shows the settings in the Details part of 

the dialog. You can add new devices by pressing the  button and remove devices by 

pressing the  button. In the Details part of the dialog you can specify the Device name, 

Vendor Name and the IP address of the DUT. You can also enter text to describe the version of the 

DUT (e.g. the HW version, the SW version and the firmware version of the DUT). This text field is 

free-format. In the Comments field you can enter any information you may find important for the 

DUT. 

The following figure shows the settings that can be configured in the Devices tab. 
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Figure 2-5 Settings > Devices 

The  button will reveal fields that might be important during the association of the 

SimFlex™ IEC 61850 Client Simulator with the DUT. By default, the pre-configured values will do for 

most DUTs. Please refer to the PICS document of the manufacturer of the DUT for information 

regarding the settings. Changing these settings might cause the SimFlexTM IEC 61850 Client Simulator 

not being able to properly connect to a DUT. 

By pressing button , Advanced setting will be hidden again. 
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Figure 2-6 Settings > Devices with Advance view 

2.5 Detailed information of Settings dialog, NIC tab 

In the NIC tab of the Settings window, the user must select the NIC interfaces for both clients, and 

one of the IP addresses that are available for each Network Interface Card (NIC) interface. The best 

configuration is when the PC has two independent Network Interface Cards, each with a different IP 

address. If your PC only has one NIC, please select that NIC for both Client 1 and Client 2, but select 

different IP addresses for both clients (both in the same IP address range as the DUT). If your PC has 

only one NIC and you see only one IP address in the drop-down list, please check you Windows OS 

manual on how to specify a second IP address on the same NIC.  

Note that the NIC addresses must be in the same sub-network as the DUT. 
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Figure 2-7 Settings > NIC 

2.6 Detailed information of Settings dialog, Globals tab 

The SimFlex™ Client Simulator is a generic IEC 61850 Client capable of running test scripts (test cases) 

against many IEDs. The test scripts are defined in such a way that they should not need alteration 

when executed. Therefore, the SimFlex™ IEC 61850 Client Simulator needs input from the test 

engineer that can to be defined in the Global tab. Most of the settings to be defined will come from 

the manufacturer’s PICS and PIXIT documents. 

NOTE: In most cases the DUT (Device Under Test) will support a subset of the conformance blocks as 

defined in the UCA© detailed test procedures for server devices. In that case only the settings for the 

applicable conformance blocks (CBs) need to be specified. 

The settings are grouped per conformance block. The settings that belong to a specific conformance 

block can be identified by the Description. The description of each setting starts with a tag that 

identifies the conformance block the setting belongs to. E.g., settings that belong to conformance 

block 1 (Basic Exchange) start with “CB01”, settings that belong to conformance block 2+ (Data Set 

Definition) start with “CB02+”, etc. 

Upon first start of application, Global tab will contain only 3 entries as shown on figure. 
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Figure 2-8 Settings > Globals before initialization 

In order to initialize all global variables to initial state it is needed to select from Test Suite, group of 

test scripts 0. Configuration along with “Delete All Variables” and “Create Global Variables” and press 

Play button. 

 

Figure 2-9 Global variables initialization 

The following figure shows part the settings that can be configured in the Globals tab. (Note: This 

figure can show different data than the form shown on your screen) 



     Page 15 

© 2011-2019 GridClone B.V. 

 
SimFlex™ Client Simulator Edition 2 – User Manual  

 

Figure 2-10 Settings > Globals after initialization 

2.6.1 Program settings 

The first three variables in the settings are informative and shall not be changed.  

GROUP NAME DESCRIPTION  VALUE  

Program 

settings 

SuiteVersion GLOB-Suite version as "Major.Minor.Date.Time" "1.0.130620.1200" 

IP1 GLOB-First IP number "192.168.0.11" 

IP2 GLOB-Second IP number "192.168.0.14" 

2.6.2 Global test suite settings 

The global test suite settings are not bound to test scripts in specific conformance block. They are 

used in test scripts throughout the whole test suite and need to be configured when applicable. The 

settings can be recognized by the “GLOB” prefix in the description column. 

GROUP NAME DESCRIPTION  VALUE  

Global 

test suite 

settings 

MinimumPDUSize 
GLOB-The smallest PDU size in bytes that the 

DUT supports (see PIXIT, e.g. 1000 bytes). 
1000 

AssociateDelayTime 
GLOB-Delay time to postpone Associate() if 

necessary (ms). 
50 

ReleaseDelayTime 
GLOB-Delay time to postpone Release() if 

necessary (ms). 
50 

KeepAliveTime GLOB-TCP keep-alive-time (ms). 5000 

KeepAliveTimeout GLOB-TCP keep-alive-timeout (sec). 10 

PowerUpTime GLOB-Power-up time of the DUT (sec). 10 

PowerDownTime GLOB-Power-down time of the DUT (sec). 10 

PredefinedDataSet 

GLOB-The object reference to a predefined 

data set, preferably with status values and 

analogue values that can be changed using an 

"" 
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GROUP NAME DESCRIPTION  VALUE  

equipment simulator. The data set elements 

shall be data attributes (FCDA), if available with 

stVal, q and t. 

PredefinedDataSetWithFCD 

GLOB-The object reference to a predefined 

data set with FCDs (=data objects), with status 

values that can be changed using an equipment 

simulator. 

"" 

DynamicDataSetSupported 
GLOB-The DUT supports dynamic data sets 

(T/F) 
F 

DynamicDataSetReference 

GLOB-Define the full object reference of a 

dataset that will be created dynamically, e.g. 

<LD>/<LN>$MyDataSet 

"" 

StValObjectReference1 

GLOB-The object reference of the first stVal 

that can be triggered using an equipment 

simulator. 

"" 

StValObjectReference2 

GLOB-The object reference of the second stVal 

that can be triggered using an equipment 

simulator. 

"" 

TimeAccuracy 

GLOB-Specify the Time Accuracy Class of the 

device as defined in the PIXIT as a string (e.g. 

T0, T1, T2...). 

"T1" 

LeapSecondsKnown 
GLOB-Specify if the device supports the 

LeapSecondsKnown (as defined in the PIXIT. 
T 

BufferOverflowEvents 
GLOB-Number of events to generate a buffer-

overflow (number, e.g. 1000) 
0 

DutNTPupdateTimeSecs 
GLOB-SNTP synchronization time/interval of 

the DUT (in seconds). 
0 

GetDataValuesSupported 
GLOB-The DUT supports the service 

GetDataValues (T/F) 
T 

2.6.3 Settings for test cases in Conformance Block 1 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 1 

MaxClients CB01-The maximum number of client 

connections the DUT can handle 

5 

WritableEnumerate CB01-The object reference of a writable 

ENUMERATED data attribute 

"" 

hasArray CB01-True if the server has arrays in the data 

model 

F 

Writable_blkEna CB01-The object reference of a writable blkEna 

reference (LD/LN$BL$DO$blkEna) 

"" 

ControllableMod CB01-The object reference of a Mod object 

that can be changed (LD/LN$CO$Mod) 

"" 

SupportedModes CB01-The supported optional modes for data 

object Mod. If NOT supported specify an 

empty string. Possible values: off, test, 

test/blocked, blocked 

{"off","test","test/blocked","

blocked"} 

HighLevelLDName CB01-The name of a LD that is referenced in a 

GrRef DO in another logical device 

"" 

MVObjectReference CB01-The object reference to an measured 

value SDO (LD/LN$MS$DO$SDO) 

"" 

SPCObjectReference CB01-CDC=SPC object reference (FC=ST, 

format LD/LN$ST$DO) that can be changed 

through the EQUIPMENT SIMULATOR. 

"" 
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GROUP NAME DESCRIPTION  VALUE  

DPCObjectReference CB01-CDC=DPC object reference (FC=ST, 

format LD/LN$ST$DO) that can be changed 

through the EQUIPMENT SIMULATOR. Leave 

empty for automatic search in data model. 

"" 

SPSObjectReference CB01-CDC=SPS object reference (FC=ST, format 

LD/LN$ST$DO) that can be changed through 

the EQUIPMENT SIMULATOR. 

"" 

DPSObjectReference CB01-CDC=DPS object reference (FC=ST, 

format LD/LN$ST$DO) that can be changed 

through the EQUIPMENT SIMULATOR. Leave 

empty for automatic search in data model. 

"" 

2.6.4 Settings for test cases in Conformance Block 2 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 2 

WritableDataSetReference CB02-The object reference of an existing data 

set with writable data set members 

"" 

NonWritableDataSetRefere

nce 

CB02-The object reference of an existing data 

set with read-only data set members 

"" 

MultiHierarchyDataSetRefer

ence 

CB02-Specify a data set that contains members 

of all possible hierarchy levels. 

"" 

2.6.5 Settings for test cases in Conformance Block 2+ 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 2+ 

NonPersistentDataSetRefer

ence 

CB02+-Non Persistent dataset reference to be 

dynamically created. Leave empty for 

automatic name creation 

"" 

NonDeletableDataSetRefere

nce 

CB02+-A pre-configured, non-deletable data 

set, not referenced in any report control block 

"" 

MaxNrOfDataSets CB02+-Maximum number of Persistent 

Datasets, e.g. 16 

0 

MaxNrOfNonPersistentData

Sets 

CB02+-Maximum number of Non Persistent 

Datasets, e.g. 10 

0 

MaxNrOfDatasetItems CB02+-Maximum number of Dataset Items, 

e.g. 100 

0 

ExcludeFC CB02+-List of Undesirable Functional 

Constraint to use in Creating Data Set 

{"BR","RP","GO","CO"} 

2.6.6 Settings for test cases in Conformance Block 4 & 4+ 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 4 

& 4+ 

SGCB CB04-The object reference of a Setting Group 

Control Block. Leave blank for automatic 

selection. 

"" 

seRefsSet CB04+-A list of each data type in the setting 

group that is writable (valKind=Set). Format: 

{"ObjRef1","ObjRef2",...} 

{"",""} 

seRefsRO CB04+-A list of each data type in the setting 

group that is NOT writable (valKind=RO). 

Format: {"ObjRef1","ObjRef2",...} 

{} 

seRef CB04+-Data reference [FC=SE]. "" 

2.6.7 Settings for test cases in Conformance Block 5 & 6 
GROUP NAME DESCRIPTION  VALUE  

Variables DataChangeST CB05/06-Unbuffered/buffered reports can be T 
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GROUP NAME DESCRIPTION  VALUE  

for 

common 

report 

test cases 

(CB 5 and 

CB6) 

 

triggered by a ST (T/F) 

DataChangeMX CB05/06-Unbuffered/buffered reports can be 

triggered by a MX (T/F) 

T 

ConfigurableDatSet CB05/6-ReportSettings: The DatSet in the RCB 

is Fix/Conf/Dyn 

"Dyn" 

ConfigurableRptID CB05/6-ReportSettings: The RptID in the RCB is 

Fix/Conf/Dyn 

"Dyn" 

ConfigurableOptFields CB05/6-ReportSettings: The OptFlds in the RCB 

is Fix/Conf/Dyn 

"Dyn" 

ConfigurableBufTime CB05/6-ReportSettings: The BufTm in the RCB 

is Fix/Conf/Dyn 

"Dyn" 

ConfigurableTrgOps CB05/6-ReportSettings: The TrgOps in the RCB 

is Fix/Conf/Dyn 

"Dyn" 

ConfigurableIntgPd CB05/6-ReportSettings: The IntgPd in the RCB 

is Fix/Conf/Dyn 

"Dyn" 

ConfigurableResvTms CB05/6-ReportSettings: The ResvTms in the 

RCB is Fix/Conf/Dyn 

"Dyn" 

Trigger 

Options 

bit-

compo-

nents 

 

data_change CB05/6-TrgOps: DUT supports data-change 

(1=yes) 

1 

quality_change CB05/6-TrgOps: DUT supports quality-change 

(1=yes) 

1 

data_update CB05/6-TrgOps: DUT supports data-update 

(1=yes) 

1 

integrity CB05/6-TrgOps: DUT supports integrity (1=yes) 1 

general_interrogation CB05/6-TrgOps: DUT supports 

general_interrogation (1=yes) 

1 

Optional 

Fields bit-

compo-

nents 

sequence_number CB05/6-OptFlds: DUT supports optional field: 

sequence-number (1=yes) 

1 

report_time_stamp CB05/6-OptFlds: DUT supports optional field: 

report-time-stamp (1=yes) 

1 

reason_for_inclusion CB05/6-OptFlds: DUT supports optional field: 

reason-for-inclusion (1=yes) 

1 

data_set_name CB05/6-OptFlds: DUT supports optional field: 

data-set-name (1=yes) 

1 

data_reference CB05/6-OptFlds: DUT supports optional field: 

data-reference (1=yes) 

1 

conf_revision CB05/6-OptFlds: DUT supports optional field: 

conf_revision (1=yes) 

1 

 

QualityChangeCfg CB05/6-DUT configuration also supports 

quality-change reports (T/F) 

T 

BufferTimeNormal CB05/6-The default value for BufTm in 

milliseconds (only change when needed) 

10000 

BufferTimeMargin CB05/6-The acceptable margin for the inter-

report time in milliseconds (needed for 

Rp7/Br7). 

1000 

IntegrityPeriod CB05/6-Default integrity period for report 

control blocks (time in ms, e.g. +0) 

0 

OwnerSCL CB05/6-Address pre-assigned in SCL as IP-

ADDRESS of the client (for example IP-address 

192.168.0.23) 

 

AnalogueDataChangeSubstituted CB05/6: A second analogue data change 

substitutes the first analogue data change 

when BufTm > 0 (check PIXIT for implemented 

F 
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GROUP NAME DESCRIPTION  VALUE  

behaviour) 

AnalogueObjectReference1 CB05/6-The object reference of the first 

analogue value that can be changed using an 

equipment simulator. 

"" 

AnalogueObjectReference2 CB05/6-The object reference of the second 

analogue value that can be changed using an 

equipment simulator. 

"" 

VolatileRCBValues CB05/6-The xRCB values ConfRev and DatSet 

are volatile, i.e. they are restored to its original 

value after a reset (PIXIT). 

F 

2.6.8 Settings for test cases in Conformance Block 5 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 5 

URCBReference CB05-The object reference to a URCB "" 

URCBReferenceANALOG 
CB05-The object reference to a URCB with a 

dataset including controllable analogue values. 
"" 

ConfiguredURCBReference 

CB05-The object reference to a Configured 

URCB with max name length, max dataset 

length, and max rptID length (sRp14). 

"" 

LargeDataSetReference 

CB05-A reference of a large data to be 

used/created for testing SEGMENTATION. 

Leave empty in case dynamic data sets are 

supported. 

"" 

PreAssignedURCBReference 
CB05-The object reference to a URCB that is 

pre-assigned to another client. 
"" 

2.6.9 Settings for test cases in Conformance Block 6 
GROUP NAME DESCRIPTION  VALUE  

Global 

Variables 

for CB 6 

BRCBReference CB06-The object reference to a BRCB "" 

BRCBReferenceANALOG CB06-The object reference to a BRCB with a 

dataset including controllable analogue values. 

"" 

ConfiguredBRCBReference CB06-The object reference to a Configured 

BRCB with max name length, max dataset 

length, and max rptID length (sBr14). 

"" 

buffer_overflow CB06-OptFlds: DUT supports optional field: 

buffer-overflow (1=yes) 

1 

entryID CB06-OptFlds: DUT supports optional field: 

entryID (1=yes) 

1 

AppMaxReports CB06-Set the approximate number of Reports 

that can be buffered (See PIXIT). 

1000 

PreAssignedBRCBReference CB06-The object reference to a BRCB that is 

pre-assigned to another client. 

"" 

2.6.10 Settings for test cases in Conformance Block 7 
GROUP NAME DESCRIPTION  VALUE  

Global 

Variables 

for CB 7 

LCBReference CB07-The object reference to a LCB "" 

LogReference CB07-Log Reference for GLOG testing "" 

GLOGRef CB07-GLOG Reference "" 

ConfigurableLCBDatSet CB07-LoggingSettings: The DatSet in the LCB is 

Fix/Conf/Dyn 

"Dyn" 

ConfigurableLogRef CB07-LoggingSettings: The LogRef in the LCB is 

Fix/Conf/Dyn 

"Dyn" 

ConfigurableLCBTrgOps CB07-LoggingSettings: The TrgOps in the LCB is "Dyn" 
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GROUP NAME DESCRIPTION  VALUE  

Fix/Conf/Dyn 

ConfigurableLCBIntgPd CB07-LoggingSettings: The IntgPd in the LCB is 

Fix/Conf/Dyn 

"Dyn" 

QueryLogByTimeSupported CB07- DUT supports QueryLogByTime (1=yes) 1 

QueryLogAfterSupported CB07- DUT supports QueryLogByTime (1=yes) 1 

2.6.11 Settings for test cases in Conformance Block 9 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 9 

GoosePublishMAC CB09-Specify the MAC address of the NIC that 

is to publish the GOOSE messages. Format "nn-

nn-nn-nn-nn-nn" or "nn:nn:nn:nn:nn:nn" 

"" 

GoCBReference CB09-Specify the GoCB reference from the SCL 

file that is used by the DUT to publish GOOSE 

messages. 

"" 

LGOSReference CB09-Specify the LGOS reference 

(LD/xxLGOSn) for the LGOS logical node that 

contains the subscription information for the 

GOOSE published by the simulator. 

"" 

MinTime CB09-The SCL MinTime for GOOSE in 

milliseconds. This is the sending delay on a 

data change between the first immediate 

sending of the change and the first repetition. 

1 

MaxTime CB09-The SCL MaxTime for GOOSE in 

milliseconds. 

0 

ExpectedResultIsSuccess_GopN1 CB09-Select the expected behaviour of the 

device: T if the GoCB can be enabled/disabled 

via SetGoCBValues (see PIXIT). 

T 

GetGoCBValuesSupported CB09-DUT supports GetGoCBValues (T/F). T 

SetGoCBValuesSupported CB09-DUT supports SetGoCBValues (T/F). F 

GooseHeaderConfRevCheck CB09-Does the DUT check the GOOSE Header 

parameter confRev (T/F) - PIXIT Gs1. 

T 

GooseHeaderNdsComCheck CB09-Does the DUT check the GOOSE Header 

parameter ndsCom (T/F) - PIXIT Gs1. 

T 

GooseRepeatCount CB09-The number times a GOOSE messages 

sent by the Client simulator for GOOSE 

subscribe testing is repeated 

10 

GooseLostTime CB09-GOOSE subscriber timeout to detect lost 

association (time in msec). 

0 

2.6.12 Common Settings for test cases in Conformance Blocks 12 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 12 

ValidOrCat CB12-Specify a SUPPORTED OrCat value for the 

DUT as specified in the PIXIT, for example: 3 

3 

InvalidOrCat CB12-Specify an UNSUPPORTED OrCat value 

for the DUT as specified in the PIXIT, for 

example: 9 

9 

OrIdent CB12-Specify the originator identification (e.g. 

000000) 

"000000" 

orIdent3 CB12-Specify the originator identification for 

remote level (orCat=3) (e.g. 000000) 

"000000" 

OperateTimeout CB12-Operate timeout of the DUT as defined 

in the PIXIT (ms) 

10000 

sboTimeout CB12-Specify the SBO timeout value as defined 30000 
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GROUP NAME DESCRIPTION  VALUE  

in the PIXIT (ms) 

TestUnselectedState CB12-Test the UNSELECTED state with 

Select/SelectWithValue (T) or Operate (F). 

T 

ParameterToChange CB12-User set the reference of a parameter 

that will be manually changed between a 

Select and an Operate in sCtl20 (see PIXIT) 

"" 

ChangeableControl CB12-User set the path of a Control object 

with a writable ctlModel, for example 

"LD_CTRL/LLN0$CO$LEDRs" 

"" 

2.6.13 Settings for test cases in Conformance Block 12a 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 12a 

DOnsObject CB12a-User set the path of a DOns object, for 

example "LD_CTRL/LLN0$CO$LEDRs" 

"" 

TADOnsObject1 CB12a-User set the path of a DOns object that 

supports TimeActivated control, for example 

"LD_CTRL/CSWI1$CO$Pos" 

"" 

TADOnsObject2 CB12a-User set the path of a second DOns 

object (TADOnsObject1 != TADOnsObject2) 

that supports TimeActivated control, for 

example "LD_CTRL/CSWI2$CO$Pos" 

"" 

TapPosDOnsObject CB12a-User set the path of a Tap Position 

DOns object, for example 

"LD_CTRL/ATCC1$CO$TapPos" 

"" 

TapChgDOnsObject CB12a-User set the path of a Tap Changer 

DOns object, for example 

"LD_CTRL/ATCC1$CO$TapChg" 

"" 

APCDOnsObject CB12a-User set the path of a APC DOns object, 

for example "LD/LN$CO$ColPos" 

"" 

ExpectedResult_Ctl10a CB12a-Select the expected behavior of the 

device as specified in PIXIT: success/no-

addcause/position-reached/time-limit 

"success" 

2.6.14 Settings for test cases in Conformance Block 12b 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 12b 

SBOnsObject CB12b-User set the path of a SBOns object, for 

example "LD_CTRL/CSWI1$CO$Pos". 

"" 

SBOnsObjects CB12b-User set the list of paths to some SBOns 

objects, for example 

{"LD_CTRL/CSWI1$CO$Pos","LD_CTRL/CSWI2$

CO$Pos"}. 

{"","","",""} 

TASBOnsObject1 CB12b-User set the path of a SBOns object that 

supports TimeActivated control, for example 

"LD_CTRL/CSWI1$CO$Pos" 

"" 

TASBOnsObject2 CB12b-User set the path of a second SBOns 

object (TASBOnsObject2 != TASBOnsObject1) 

that supports TimeActivated control, for 

example "LD_CTRL/CSWI2$CO$Pos" 

"" 

TapPosSBOnsObject CB12b-User set the path of a Tap Position 

SBOns object, for example 

"LD_CTRL/ATCC1$CO$TapPos" 

"" 

TapChgSBOnsObject CB12b-User set the path of a Tap Changer 

SBOns object, for example 

"" 
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GROUP NAME DESCRIPTION  VALUE  

"LD_CTRL/ATCC1$CO$TapChg" 

APCSBOnsObject CB12b-User set the path of a APC SBOns 

object, for example "LD/LN$CO$ColPos" 

"" 

ExpectedResult_Ctl10b CB12b-Select the expected behavior of the 

device as specified in PIXIT: success/no-

addcause/position-reached/time-limit 

"success" 

2.6.15 Settings for test cases in Conformance Block 12c 
GROUP NAME DESCRIPTION  VALUE  

Variables 

for CB 12c 

DOesObject CB12c-User set the path of a DOes object, for 

example "LD_CTRL/LLN0$CO$LEDRs" 

"" 

TADOesObject1 CB12c-User set the path of a DOes object that 

supports TimeActivated control, for example 

"LD_CTRL/CSWI1$CO$Pos" 

"" 

TADOesObject2 CB12c-User set the path of a second DOes 

object (TADOesObject1 != TADOesObject2) 

that supports TimeActivated control, for 

example "LD_CTRL/CSWI2$CO$Pos" 

"" 

TapPosDOesObject CB12c-User set the path of a Tap Position DOes 

object, for example 

"LD_CTRL/ATCC1$CO$TapPos" 

"" 

TapChgDOesObject CB12c-User set the path of a Tap Changer 

DOes object, for example 

"LD_CTRL/ATCC1$CO$TapChg" 

"" 

APCDOesObject CB12c-User set the path of a APC DOes object, 

for example "LD/LN$CO$ColPos" 

"" 

ExpectedResult_Ctl10c CB12c-Select the expected behavior of the 

device as specified in PIXIT: success/position-

reached/time-limit 

"success" 

ExpectedResult_Ctl14c CB12c-Select the expected behaviour of the 

device as specified in PIXIT: success/command-

already-in-execution 

"success" 

2.6.16 Settings for test cases in Conformance Block 12d 
GROUP NAME DESCRIPTION  VALUE  

Variables for 

CB 12d 

SBOesObject CB12d-User set the path of a SBOes object, for 

example "LD_CTRL/CSWI1$CO$Pos" 

"" 

SBOesObjects CB12d-User set the list of paths to the SBOes 

objects, for example 

{"LD_CTRL/CSWI1$CO$Pos","LD_CTRL/CSWI2$

CO$Pos"}. 

{"","","",""} 

TASBOesObject1 CB12d-User set the path of a SBOes object 

that supports TimeActivated control, for 

example "LD_CTRL/CSWI1$CO$Pos" 

"" 

TASBOesObject2 CB12d-User set the path of a second SBOes 

object (TASBOesObject2 != TASBOesObject1) 

that supports TimeActivated control, for 

example "LD_CTRL/CSWI2$CO$Pos" 

"" 

TapPosSBOesObject CB12d-User set the path of a Tap Position 

SBOes object, for example 

"LD_CTRL/ATCC1$CO$TapPos" 

"" 

TapChgSBOesObject CB12d-User set the path of a Tap Changer 

SBOes object, for example 

"" 
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GROUP NAME DESCRIPTION  VALUE  

"LD_CTRL/ATCC1$CO$TapChg" 

APCSBOesObject CB12d-User set the path of an APC SBOes 

object, for example "LD/LN$CO$ColPos" 

"" 

ExpectedResult_Ctl10d CB12d-Select the expected behavior of the 

device as specified in PIXIT: success/select-

position-reached/select-time-limit/position-

reached/time-limit 

"success" 

2.6.17 Settings for test cases in Conformance Block 13 
GROUP NAME DESCRIPTION  VALUE  

Variables for 

CB 13 

EventDrivenUTCTime CB13-An object reference to a UTC timestamp 

triggered by an event created by the 

Equipment Simulator, for example 

"LD_CTRL/CSWI1$ST$Pos$t". Leave empty for 

GOOSE only devices. 

"" 

SNTPSyncPeriod CB13-Specify the period (seconds) for the 

device to synchronize to an SNTP time server. 

30 

SyncLosingPeriod CB13-Specify the period (seconds) after which 

the device detects a lost time sync. 

0 

DisturbanceRecordDir CB13-Specify the directory in the DUT where 

disturbance records are stored. 

"" 

2.6.18 Settings for test cases in Conformance Block 14 
GROUP NAME DESCRIPTION  VALUE  

Variables for 

CB 14 

LargeFileReference CB14-Select the path to a large file for Ft4, the 

bigger the file the more likely the test will be 

successful. Leave it empty for automatic file 

selection. 

"" 

LocalFileDir CB14-Specify a directory containing files that 

can be uploaded to the DUT. 

"" 

RemoteFileDir CB14-Specify a directory that can be written in 

the DUT. 

"" 

maxFileSizeBytes CB14-Specify the maximum supported file size 

by the DUT in bytes. 

1048576 

ExpectedResultIsSuccess_Ft4 CB14-Select the expected behavior of the 

device as specified in PIXIT 

T 

2.6.19 Settings for test cases in Conformance Block 15 
GROUP NAME DESCRIPTION  VALUE  

Variables for 

CB 15 

URCBReferenceTrk CB15-The object reference to a URCB used for 

Tracking service. 

"" 

BRCBReferenceTrk CB15-The object reference to a BRCB used for 

Tracking service. 

"" 

LCBReferenceTrk CB15-The object reference to a LCBR used for 

Tracking service. 

"" 

DataSetTrk CB15-The reference to a DataSet used for 

Tracking service. 

"" 

BRCBReferenceToTrk CB15-The object reference to a BRCB 

referenced in Tracking service. 

"" 

URCBReferenceToTrk CB15-The object reference to a URCB 

referenced in Tracking service. 

"" 

LCBReferenceToTrk CB15-The object reference to a LCB referenced 

in Tracking service. 

"" 
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GROUP NAME DESCRIPTION  VALUE  

GoCBReferenceToTrk CB15-The object reference to a GCB 

referenced in Tracking service. 

"" 

MSVCBReferenceToTrk CB15-The object reference to a MSVCB 

referenced in Tracking service. 

"" 

USVCBReferenceToTrk CB15-The object reference to a USVCB 

referenced in Tracking service. 

"" 

SgcbReferenceToTrk CB15-The object reference to a SGCB 

referenced in Tracking service. 

"" 

SpcObjectToTrk CB15-The object reference to a SPC referenced 

in Tracking service. 

"" 

DpcObjectToTrk CB15-The object reference to a DPC 

referenced in Tracking service. 

"" 

IncObjectToTrk CB15-The object reference to a INC referenced 

in Tracking service. 

"" 

EncObjectToTrk CB15-The object reference to a ENC 

referenced in Tracking service. 

"" 

IscObjectToTrk CB15-The object reference to a ISC referenced 

in Tracking service. 

"" 

BscObjectToTrk CB15-The object reference to a BSC referenced 

in Tracking service. 

"" 

ApcFObjectToTrk CB15-The object reference to a APC Float 

referenced in Tracking service. 

"" 

ApcIntObjectToTrk CB15-The object reference to a APC Integer 

referenced in Tracking service. 

"" 

 



     Page 25 

© 2011-2019 GridClone B.V. 

 
SimFlex™ Client Simulator Edition 2 – User Manual  

3 Use case: Starting and stopping SimFlex CS 

3.1 Verify a connection with a DUT 

Make sure that both IED and the PC that is running the SimFlex CS are connected to the same 

network and that they are in the same IP address range. 

Example: 

IED 

IP address = 192.168.0.100, mask = 255.255.255.0 

SimFlex Client Simulator 

IP address = 192.168.0.90, mask 255.255.255.0 

Choose the right interface that connects the client (PC used to run SimFlex CS) and the server/device. 

NOTE: Please check your Windows OS manual on how to change adapt the IP address and network 

mask. 

3.2 Start SimFlex CS 

Open the SimFlexTM IEC 61850 Client Simulator as you would normally open any Windows 

application. You may find a link under the Start menu in the GridClone folder. 

Another way to start the program is to double-click the SimFlexTM IEC 61850 Client Simulator icon on 

the desktop (available when this option has selected during the installation of the software).  

3.3 Configure the right network adapter in SimFlex CS 

Please check chapter 2.5 Detailed information of Settings dialog, NIC tab for more information on 

how to configure the network interface cards in the SimFlex™ IEC 61850 Client Simulator. 

3.4 Select, Edit or Add a DUT to SimFlex CS 

Use the menu item Devices to Edit, Add or Select devices. 
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Figure 3-1 Edit, Add or Select device from Menu bar 

You may also use the button Devices. 

 

Figure 3-2 Edit, Add or Select device from Tool bar 
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3.5 Build the data model 

Hover over the icon "Double click to start creation of data model". The user can choose between 

build normal Data Model or Data Model with additional Read/Write information, which will be more 

useful but take longer time to be generated. 

 

Figure 3-3 Build Datamodel 
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4 Use case: Run a single test 
This section explains what a test suite is, how to load a test suite into SimFlex CS, how to run one or 

more tests and how to evaluate the results of the run tests. 

First of all, what is a test suite? A test suite is a compilation of several test scripts grouped together in 

one file. The extension of test suite files is “.suite”. In addition to the test scripts, a test suite also 

contains the global variables and some metadata. Internally it is XML file but it is not intended to be 

edited by the end user, instead the SimFlex CS should be used for any editing of a test suite. 

4.1 Open a test suite 

In order to load a test suite from the SimFlex CS the user has several options:  

1) Click in the menu bar under: File→ Open → Open Test Suite, then select a test suite in the 

Open Test Suite dialog window. 

 

Figure 4-1 Open Test Suite from Menu bar 

2) Click in the tool bar button: Open →Open Test Suite, then select a test suite in the Open Test 

Suite dialog window. 

 

Figure 4-2 Open Test Suite from Tool bar  

3) Press the shortcut CTRL + O and then select a test suite in the Open Test Suite dialog window. 
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Figure 4-3 Open Test Suite 

NOTE: The Open Test Suite dialog window will be opened in the Test suites folder (by default in 

“C:\ProgramData\GridClone\SimFlex\TestLab\TestSuites”). If the user changes the “Application base 

folder” as explained in chapter 2.3 Detailed information of Settings dialog, General tab the Test 

Suites folder will change accordingly. 

NOTE: Initially the folder “C:\ProgramData\GridClone\SimFlex\TestLab\TestSuites” might not contain 

the IEC 61850 Edition 2 test suite. In that case the test suite is located in the installation folder of the 

SimFlex CS, e.g. “C:\Program Files (x86)\GridClone\SimFlex Client Simulator\Testsuites” (32bit / 

64bits version of Windows). 

It is also possible to load a recently opened test suite selecting the wanted test suite from the menu 

bar under: File→ Open Recent and selecting a “.suite” file. 

 

Figure 4-4 Open recent Test Suite 

4.2 Test suite tree panel and script tabs 

Providing that the file is a valid suite file, it will be shown in the left panel of the SimFlex CS. 

The top label (1) shows the name and version of the loaded test suite. The central part (2) shows a 

tree model of the test suite with conformance blocks as nodes (3) and test scripts as leaves (4). 

Finally, the lower part of the panel (5) shows details of the selected (if any) test script or 

conformance block. 

 



     Page 30 

© 2011-2019 GridClone B.V. 

 
SimFlex™ Client Simulator Edition 2 – User Manual  

 

Figure 4-5 Test Suite Tree view 

The content of the test scripts can be shown by double clicking in a test script. A tab will be opened 

in the central panel of the SimFlex CS as shown in the next figure: 

1 

2 

3 

4 

5 
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Figure 4-6 Opened Test Script 

NOTE: Initially, opened test script will be disabled for editing, thus there will be grey background. 

4.3 Select and run test scripts 

Select at least one test script in at least one conformance block and then click the Run button. 

 

Figure 4-7 Select and Run Test Script 

If more than one test script is selected in the active conformance block and/or more than one 

conformance block is selected with active scripts in it, all of the active scripts will be run sequentially 

from the top. 

The user might stop the tests pressing the Stop button that is located next to the Run button. The 

current running test will be aborted and none of the remaining tests will be run. 
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Figure 4-8 Abort Test Script 

While a test is running, some log messages will be shown in the Log panel. This panel shows useful 

information of every step in the script and it is invaluable to know why a test is failing. 

 

Figure 4-9 Log messages 

It is possible to select and deselect all scripts in the suite by right-clicking anywhere in the suite and 

selecting Suite → Select All | Deselect All. 
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Figure 4-10 Suite > Select All/Deselect All 

It is also possible to select and deselect all scripts in a group by right-clicking in a script or group and 

then selecting Group → Select All | Deselect All. 

 

Figure 4-11 Group > Select All/Deselect All  
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4.4 Evaluate test results 

Each script may have a status indication in the left panel as shown in the following figure: 

 

Figure 4-12 Test Status indications 

The currently running test will have the Running status icon (blue). All run tests will have either the 

Pass (green) or the Fail (red) status icon. The Inconclusive (yellow) status can only be set manually. 

The user can override the result status of any test (e.g. if the test engineer sees some non-

conformant behaviour in the device) by right clicking at the test script and clicking on Change Status 

→ (Passed | Failed | Inconclusive | Unknown). 
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Figure 4-13 Change Status 

4.5 Open and examine a log file 

If a test that has already been executed is selected, the Log panel will show the log file for that 

specific test. The log file contains the same information as shown while running the test, and also 

shows a header and footer with useful information. 

The log file can also be opened with an external editor (e.g. Notepad). Right click on the desired test 

and then Open → Log file. 
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Figure 4-14 Open Log file 

Windows will choose the default application for text files and open the selected log file. You can 

change the default application for text files in the Windows settings. 

4.6 Open and examine a capture file 

In addition to log files, the SimFlex CS also stores a capture file of all the Ethernet packets in the 

network. That capture file can be opened and examined by right clicking in an already executed test 

and then Open → Capture file. Windows will choose the default application for “.pcap” files. You can 

change the default application in the Windows settings. 

NOTE: To view the capture file, a third-party tool capable of showing the contents of the “.pcap” file 

format needs to be installed. A well-known example is Wireshark (see http://www.wireshark.org/). 

If installed, the capture file can also be opened in the SimFlex™ Protocol Analyzer. If right click and 

then Open → Protocol Analyzer is selected, a new session of SimFlex™ Protocol Analyzer will be 

started, the capture file will be opened and Analyze will be run. 

http://www.wireshark.org/
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Figure 4-15 Open Capture file 

4.7 Save and close a test suite 

After modifying the selection of scripts, the Global Settings (as explained in chapter 2.6) or the 

contents of a script (as will be explained in Section 6) the user may want to save the test suite 

manually. In order to do so there are two methods: 

1) Click in the menu bar under: File→ Save → Save Test Suite. 

 

Figure 4-16 Save Test Suite from Menu bar 
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2) Click in the tool bar button: Save →Save Test Suite. 

 

Figure 4-17 Save Test Suite from Tool bar 

3) Press the shortcut CTRL + S. 

Additionally, test suites will be automatically saved in the following cases: 

- before a test is run, 

- before the suite is closed (with a confirmation warning) and 

- before the application is closed (with a confirmation warning). 

The user may want to save the test suite as a different file. To do so: 

1) Click in the menu bar under: File→ Save → Save Test Suite As... 

 

Figure 4-18 Save As Test Suite from Menu bar 

2) Click in the tool bar button: Save →Save Test Suite As... 
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Figure 4-19 Save As Test Suite from Tool bar 

The user can close a test suite manually by clicking in the menu bar under: File → Close Test Suite. 

 

Figure 4-20 Close Test Suite 

Other actions that will close the test suite are: 

- opening another test suite, 

- opening or creating a test session and 

- closing the application. 
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5 Use case: Run a session 
This section explains what a test session is, how to create or load a test session into SimFlex CS, how 

to run one or more tests in a session and how to evaluate the results of the run tests. 

First of all, what is a test session? 

A test session is a compilation of a test suite and session information like DUT, test lab, vendor and 

settings grouped together in one file. The extension of test session files is “.tsf”. Internally it is XML 

file but it is not intended to be edited by the end user, instead the SimFlex CS should be used for any 

editing of a test session. 

Note that test sessions created with SimFlex™ CS Edition 1 cannot be loaded with SimFlex™ CS 

Edition 2 due to differences in model and test structures. 

5.1 Create a test session 

A test session can be created in two different ways: 

1) Click in the menu bar under: Test Session→ Create. 

 

Figure 5-1 Create Test Session from Menu bar 

2) Click in the tool bar button: Create a new test session. 

 

Figure 5-2 Create Test Session from Tool bar 

The next step is to select a DUT for the session as shown in the next figure: 
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Figure 5-3 Select Device 

Also, a test suite must be selected as shown in the next figure: 

 

Figure 5-4 Test Suite Selection 

Finally, the user must fill in the session information in the session settings form. The several fields to 

fill in will be explained in a following section. For now, the session name and test session number are 

the only mandatory fields to be filled in. 
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Figure 5-5 Test Session settings 

5.2 Open a test session 

In order to open a test session that was previously saved, the user has several options:  

1) Click in the menu bar under: File→ Open → Open Test Session, then select a test session in 

the Open Test Session dialog window. 

 

Figure 5-6 Open Test Session from File menu 

2) Click in the menu bar under: Test Session→ Open, then select a test session in the Open Test 

Session dialog window. 
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Figure 5-7 Open Test Session from Test Session menu 

3) Click in the tool bar button: Open → Open Test Session and then select a test session in the 

Open Test Session dialog window. 

 

Figure 5-8 Open Test Session from Tool bar 

4) Press the shortcut ALT + O and then select a test session in the Open Test Session dialog 

window. 

 

Figure 5-9 Selection of Test Session for opening 

NOTE: The Open Test Session dialog window will be opened in the Sessions folder (by default in 

“C:\ProgramData\GridClone\SimFlex\Sessions”). If the user changes the “Application base 

folder” as explained in Section 2 the Sessions folder will change accordingly. 

It is also possible to load a recently opened test session selecting the wanted test session from the 

menu bar under: File→ Open Recent and selecting a “.tsf” file. 
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Figure 5-10 Open Recent Test Session 

5.3 Run tests in ‘non-recording’ mode 

Tests can be run as explained in Section 4. One or more test scripts and conformance blocks can be 

selected and run. The status icons will change accordingly and the log files and capture files can be 

inspected as explained in Section 4. 

Evaluating the test results and opening log and capture files can be accomplished as explained in 

Section 4. 

Running scripts in this mode is intended for fine-tuning or adjusting the settings of the DUT, suite 

and/or session. After that, the test engineer may want to go on ‘record’ mode. 

5.4 Run tests in ‘recording’ mode 

The user can press the Record button  to go on ‘recording’ mode. The Record button will be 

disabled and a new Stop button will be enabled. To stop recording the session press the Stop 

button. 

 

Figure 5-11 Test Session Tool bar 

Another side effect of going into ‘recording’ mode is that all status icons of the scripts run in ‘non-

recording’ mode will be cleared. Some other scripts may be set to other statuses depending on 

previous runs in ‘recording’ mode. In short, when a test is run in ‘recording’ mode its status, log file 

and capture file information will be stored in the session file. Thus, that information can be retrieved 

at any moment by the test engineer. Note that only the last run of the script will be stored, the user 

must take care of not overwriting the results by re-running the test. 

To run a test, like in the other cases, select the appropriate tests and press the Run button. A warning 

window may appear before and after running the tests to confirm the overwriting of the test session 

file. The first confirmation allows overwriting any changes in the test suite and the second one allows 

overwriting of the test results. 

Evaluating the test results and opening log and capture files can be accomplished as explained in 

Section 4. If for any reason, the test engineer desires to overwrite a test status, it can be done as 
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explained in Section 4. This value will be stored in the session file and will be available in future runs 

of the session. 

5.5 Save and close test sessions 

After modifying a session, it can be manually saved by three methods: 

1) Click in the menu bar under: File→ Save → Save Test Session. 

 

Figure 5-12 Save Test Session from Menu bar 

2) Click in the tool bar button: Save →Save Test Session. 

 

Figure 5-13 Save Test Session from Tool bar 

3) Press the shortcut CTRL + ALT + S. 

Additionally, test sessions will be automatically saved (with a confirmation warning) in the following 

cases: before and after a test is run, before the session is closed and before the application is closed. 

The user can close a test session manually by: 

1) Clicking in the menu bar under: Test Session → Close. 
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Figure 5-14 Close Test Session from Menu bar 

2) Clicking in the tool bar button: Close Test Session. 

 

Figure 5-15 Close Test Session from Tool bar 

5.6 Modify and copy test sessions 

In addition to changes in the session’s tests and results, the user can modify the session settings by: 

1) Clicking in the menu bar under: Test Session → Settings. 

 

Figure 5-16 Test Session Settings from Menu bar 

2) Clicking in the tool bar button: Test Session Settings. 

 

Figure 5-17 Test Session Settings 
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The session settings window will appear as shown in next figure: 

 

Figure 5-18 Test Session Settings dialogue 

The following fields can be changed freely as they are only used as information containers: ‘Test 

status’, ‘Test lab’ address, ‘Customer’ address, DUT ‘Version’, ‘Test setup’ and ‘Comments’. After 

modifying any of these fields, the user can press the ‘Ok’ button to store the settings or the ‘Cancel’ 

button to discard the changes. After pressing ‘Ok’ a confirmation window will appear. 

 

Figure 5-19 Test Session already exist notification 

Special care must be taken with the ‘Session name’ and ‘Test order number’ fields because these two 

have side effects. Namely, changing the session name will also change the file name in which the 

session is saved. Changing the ‘Test order number’ will prompt a warning window. Pressing ‘Yes’ will 

copy the current session (with the exception of the test results) to a new folder location. Pressing 

‘No’ will rename the current session. 
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Figure 5-20 Test Order Nr notification 

More information on the file/folder structure of sessions can be found in Section 6. 

Additionally, the user may also access the session settings window by: 

1) Click in the menu bar under: File→ Save → Save Test Session As... 

 

Figure 5-21 Save Test Session from File menu 

2) Click in the tool bar button: Save →Save Test Session As... 

 

Figure 5-22 Save Test Session from Tool bar 

An informative window will be opened and after clicking OK on it the Test Session Settings window 

will be shown. 
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Figure 5-23 Save Test Session As notification 

5.7 Use the issues tab 

The ‘Issues’ tab in the lower panel is a small utility to assist the user in writing down and keeping 

track of issues that appear while testing a device. The tab is only enabled inside sessions. 

 

Figure 5-24 Issue Tab 

New issues can be added pressing the Add button. In the following window the appropriate 

information can be filled in. Issues can also be edited by double-clicking on them. 
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Figure 5-25 Issue details 

The issues can be filtered by category, can be imported from other issue files, can be manually saved 

and refreshed by using the buttons in the top of the tab. 
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6 Advanced use 

6.1 Global settings 

Section 2 described the way to access the  tab and that it is used for configuration of the 

global settings or variables used through the SimFlexTM IEC 61850 Client Simulator. 

 

Figure 6-1 Settings window, Globals tab 

The tab has a small toolbar used (from left to right) for: 

- navigation,  

- remove variable,  

- add new variable,  

- refresh variable and  

- get help. 

 

Figure 6-2 Toolbar in Globals tab 
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6.1.1 Columns in the Global Settings Tab 

Name: This column is listing the Global variable names that is used in the test scripts. Variables in the 

global settings can be invoked/used in the test scripts. Once assigned, the name cannot be changed 

and also the Locked flag is off. (See below) 

Description: This Column describe briefly about the specific global variable and how it is configured. 

Value: This column has to have a value to the specific global variable and cannot be left empty. Value 

type declaration will be explained below. 

Locked: If this feature is ticked, all the columns are locked and the user cannot edit the related rows. 

This will also prevent scripts from changing the value by accident. 

6.1.2 Global variable format 

This part describes the types available for the Global variable and how it is 'serialized' into a text 

string. Used types are declared in following table. 

Type Description Example 

BOOLEAN 

BOOLEAN type is declared either with T or F. 

Note: The texts True and False will be 

converted to T and F. 

T, F 

INTEGER 

INTEGER type is explicitly declared with 

numerical int the column 

Note: Do not use the '+' sign, see UNSIGNED 

INTEGER. 

1234567890, -1234567890 

UNSIGNED 

INTEGER 

UNSIGNED INTEGER type is explicitly 

declared with numerical in the column 

Note: The '+' sign forces it to be an unsigned 

integer. 

+1234567890 

STRING 

STRING type is declared with "". 

Note: The double quotes are *not* optional 

and must be included. 

"this is how it is declared." 

BITSTRING 
BITSTRING type is declared as a list of zeros 

and ones within square brackets.  
[010011010110] 

STRUCTURES AND 

LISTS 

STRUCTURE and LIST types are declared as a 

comma-separated list of other types within 

curly brackets. 

{"first element", 2, +3, 

{"nested", "structure"}} 
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6.2 More on Scripts 

Section 4 described how to run test scripts. A script can be opened by double-clicking on it. 

 

Figure 6-3 Opening a test script 

By default, test suites or sessions are opened in read-only mode. That is, the script can be examined 

by the user but not modified. Examination can be done by scrolling down and up like in a traditional 

text editor. 

In order to modify the content of the script click on the  button: 

 

Figure 6-4 Unlock test script 

After editing the script, it is recommended to protect it against accidental modification by clicking on 

the   button. 
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Figure 6-5 Lock test script 

6.2.1 IEC 61850 and UCA test procedures 

IEC 61850-10 defines the methods and abstract test cases for conformance testing of devices used in 

substation automation systems. It also defines the metrics to be measured within devices according 

to the requirements defined in IEC 61850-5. Part 10 of the IEC 61850 standard specifies the basic 

types of tests required to label a device “IEC 61850 conformant” but it leaves details of the tests 

open to interpretation. 

The Utility Communications Architecture International Users’ Group (UCA IUG) formed a Testing 

Committee to review the collective needs of device users and device providers for Conformance 

testing. The Testing Committee’s mandate is to create a conformance test system compliant to all 

parts of IEC 61850 which would meet the needs of users. 

The testing committee has created three major documents as the core of the test system: IEC 61850 

Conformance Testing: 

• The Accreditation Program. This document specifies what conditions an organization must 
meet before it can claim to be a UCA IUG-recognized (accredited) IEC 61850 conformance 
tester.  

• Quality Assurance Procedures. This document specifies the rules users and conformance 
testers must follow to ensure that interoperability issues discovered in real systems are 
prevented by improved wording in future versions of the specification. 

• Test Procedures. This document contains detailed step-by-step rules for conducting 
conformance tests. These rules encode tests for not only normal operating conditions 
(positive tests) but also as many error conditions (negative tests) as possible. These test 
procedures reference the conformance testing specified in IEC 61850 Part 10. 

 

The test suite provided with the SimFlex™ IEC 61850 Client Simulator implements the test 

procedures described in “Conformance Test Procedures for Server Devices with IEC 61850-8-1 Edition 

2 interface. Revision 2.0”, specifically in annex “A4. Mapping of ACSI models and services (IEC 61850-

7-2 and applicable SCSM)”. 

6.2.2 Script structure and language 

The SimFlex™ IEC 61850 Client Simulator uses Python as the programming language for the test cases 

because it is a high-level programming language, easily understandable and configurable. The user 

must be familiar with this language’s syntax in order to edit the scripts. 

The scripts do not expose the whole Python language; they only use a small subset that can be learnt 

in minutes by anyone with any previous experience with some kind of computer programming. Many 

books and tutorial exist covering the basic Python syntax. 
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Once familiar with the syntax, the structure of the scripts will be clear to the user.  

 

Figure 6-6 Test Script example 

All of them start with a (optional) declaration of global variables used in the script. Then some kind of 

initialization follows. The test procedure begins after the BeginTest() call. In the script body several 

function calls, variable assignations, execution control blocks and loops are performed. Finally, the 

test procedure ends with the EndTest() call. Note that the script body tries to follow the test 

procedure as closely as possible in a literal sense. 

If SimFlex™ Protocol Analyzer is installed, the test can be extended with analyzes. To implement this, 

add “FinalResult = Analyze()”  to the script. This call must be inserted after “EndTest()” (because the 

capture file has to be closed and that is done in “EndTest()”.If SimFlex™ Protocol Analyzer is not 

installed, Analyze() will return Testresult.PASS. 

6.2.3 Function calls 

In addition to Python syntax and the use of global variables, the SimFlex™ Client Simulator exposes 

an API to interact with the DUT. The API can be inspected in the online help by clicking in the menu 

Help → SimFlex CS Python API. 
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Figure 6-7 SimFlex CS Python API menu 

A help file will be opened with the aforementioned API documentation: 

 

Figure 6-8 SimFlex CS Python API Docs 

6.3 External Python Source usage 

6.3.1 Inclusion of an external Python source file 

The SimFlex™ IEC 61850 Client Simulator is using an IronPython engine that executes test cases that 
contain Python source code. When selecting one or more test cases in the test suite the SimFlex™ IEC 
61850 Client Simulator assembles a single Python source file from all selected test cases and adds 
additional code before, after and in between the scripts. This assembled Python source file is then 
interpreted and executed by the IronPython engine. 

By default, it is not possible to create Python functions in the SimFlex™ IEC 61850 Client Simulator. 
However, in some cases it is desired to created special functions that can be called in the test cases. 
To enable this feature the SimFlex™ Client Simulator can include an external IronPython source code 
file. Currently this has been implemented as follows: 

1) The user creates a new environment variable in the Windows, called SimflexIpyExternal. 
How to create a new variable depends on the Windows version. Please check the Windows 
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help function for more information (on Figure 6-9 Creation of new environment variable is 
example from Microsoft Windows 10). In this example is presented definition of the 
environment variable and assigning of value “D:\”.  

 

Figure 6-9 Creation of new environment variable 

2) Next the user can create one or more IronPython compatible files in an (external) editor and 
store the files in the defined location, in this case “D:\”. The files shall have the extension 
“.py”. 

3) The IronPython engine inside the SimFlex™ IEC 61850 Client Simulator now includes the 
Python files in the total IronPython source file assembly, before any selected test script in the 
test suite. The external Python files are included in an alphabetical order. 

The user can also specify multiple paths in the environment variable. Each path shall be separated by 
a semi-colon (;). An example of multi-path definition is shown below: 



     Page 58 

© 2011-2019 GridClone B.V. 

 
SimFlex™ Client Simulator Edition 2 – User Manual  

 

Figure 6-10 Edit of SimflexIpyExternal 

In this case the IronPython engine inside the SimFlex™ IEC 61850 Client Simulator includes all python 
files (*.py) from every specified folder. The order of inclusion of all python files is as follows: 

1) Each specified folder from left-to-right 

2) All Python files (*.py) in each specified folder in alphabetical order 

NOTE: In case the environment variable contains a folder that has no Python files (*.py), the folder is 
simply skipped. 

 

6.3.2 Creating an external process from a script 

In some cases, it is desired to start a process that executes an application, e.g. to control some 
external hardware through its own command-line application. For this purpose, it is possible to call a 
Python function named CreateProcess: 

def CreateProcess(executablePath, executableArguments="", waitForExit=-1) 

 

The parameters are defined as follows: 

executablePath This is the full path and application name to be executed on the local PC, 
e.g. “C:\Program Files (x86)\Notepad++\Notepad++.exe” 

executableArguments This is a string specifying all the applicable command line parameters for 
the application to be executed, e.g. “—help”. This parameter is optional 
and by default empty (“”).  

waitForExit This is a signed integer (32 bit) that specifies the amount of time, in 
milliseconds, to wait for the associated process to exit. The maximum is 
the largest possible value of a 32-bit signed integer (approximately 24.8 
days). Possible values are: 
-1 : This is the default value and starts the process asynchronously, 
meaning the call to CreateProcess return immediately.  
0 : Wait indefinitely for the process to exit. 
1 – 2,147,483,647 : Wait until the process terminates, but no longer than 
the specified number of milliseconds. 

The function CreateProcess does not return a value. 

6.4 How to use the data model 

Section 0  
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Use case: Starting and stopping SimFlex CS describes the procedure to build the DUT’s data model. 

After doing so, the data model will be shown in the right panel as shown in the next figure: 

 

Figure 6-11 Data model tree 

6.4.1 Tree hierarchy 

Tree hierarchy is containing following nodes: 

 LD = Logical Device 

 LN = Logical Node 

 FC = Functional Constraint 

 DO = Data Object 

 DA = Data Attributes 

6.4.2 How to read the values in the DUT data model (MMSData values) 

All values from and to a DUT are communicated using the MMS protocol (ISO 9506), as described in 

IEC 61850-6. Values shown in the DUT data model are restricted to the format described within the 

MMS protocol. 

The values displayed in the DUT data model do not only contain the MMSData type but also includes 

some length information, a flag indicating if the value is ‘Readable’, ‘Writable’ or both and the actual 

value retrieved from the DUT. 

The normal format for an item with a value in the data model is: 
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Name, [MMSData type], Readable/Writable flag, value. 

Example: 

DUT_NAME [DUT IP address] 

 Data Model 

  LD name 

   FC ST 

    DO Mod 

     DA stVal, [INTEGER~8], R., value = 1 

     DA q, [BITSTRING~-13], R., value = [0000000000000] 

     DA t, [UTC_TIME], R., value = u23-11-2012_17:05:57.720 

6.4.3 MMSData type and length information: 

The length information with the MMSData type is according to IEC 61850-8-1, paragraph 8.1, table 

11, mapping of ACSI data types. 

Most MMSData types with a fixed length (such as UTC_TIME) have no length information, with the 

exception of BOOLEAN. INTEGER and UNSIGNED which have length information of one digit (8 for 8 

bits, 16 for 16 bits etc.). String based types (such as VISIBLE_STRING) have length information that 

can be negative indicating a Maximum length (the string may be shorter than the length but only if 

the length information is negative.). And FLOATINGPOINT values have two length information values, 

one to indicate the total length (in bits) and the second to indicate the length of the exponent (in 

bits). 

Readable/Writable: 

At maximum two characters indicate the data attribute readable/writable information. The possible 

characters are: 

Character Meaning 

- The Readable/Writable state is unknown. 

. The Readable/Writable state is untested. 

R The data attribute is Readable 

W The data attribute is Writable 

w The data attribute should be writable but is not available at the moment for writing. 

The most common combinations are: 

Combination Meaning 

- The data attribute Readable/Writable state is unknown. 
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. The data attribute Readable/Writable state is untested. 

R. The data attribute is Readable but not tested for Writable. 

R- The data attribute is Readable but not Writable. 

Rw The data attribute is Readable and should be Writable but was not available for 

writing at the moment of testing. 

RW The data attribute is Readable and Writable. 

6.5 More on configuration files 

Several files can be edited to alter some of the behaviour of the SimFlexTM IEC 61850 Client 

Simulator. 

6.5.1 Log file customization 

As explained in Section 4, the log text generated for each test script is stored in disk. Depending if the 

test is run in a session or not it is store under the ‘Application base directory’ folder in: 

• Session (not recording): ‘.\Sessions\%VENDOR%\%DEVICE%.%NR%\Pre-Test\’ 

• Session (recording):  ‘.\Sessions\%VENDOR%\%DEVICE%.%NR%\Test\’ 

• No Session: ‘.\TestLab\TestBenches\%TESTBENCH%\Pre-Test\’  

The log file has some headers and footers at the beginning and ending. This header and footers can 

be customized by the user. Log file customization is done by modifying the 

‘.\TestLab\LogHeaders.xml’ file. 
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Figure 6-12 LogHeaders.xml 

Two kinds of XML elements can be added to this file: HEADER and FOOTER elements: 

• HEADER_ELEMENTs are used in log files generated by test scripts. They are displayed before 
the logging itself in the order found in this file. 

• FOOTER_ELEMENTs are used in log files generated by test scripts. They are displayed after 
anything else in the order found in this file. 

Each element can be of either one of three different types: MAIN, CS and SCL. 

• MAIN types are used as a title for program log files. They are displayed before anything else 
in the order found in this file. 

• CS types are used as a header for script log files in the SimFlexTM IEC 61850 Client Simulator. 
They are displayed before anything else in the order found in this file. 

• SCL types are used as a header for script log files in the SimFlex™ IEC 61850 SCL Checker. 
They are displayed before anything else in the order found in this file. 

Variables in the form of %VAR% can be used inside the element inner text. Two kinds of variables can 

be used: default variables defined in the SimFlex™ tool and environment variables defined by the 

user or the OS. 

NOTE 1: Environment variables will be checked before the default SimFlex™ variables, thus 

environment variables override the default values. Take this into account when creating new 

environment variables. 

NOTE 2: Some default variables are not applicable at some points, e.g. session information is only 

available while running a session. When this is the case they will be translated as "NOT-APPLICABLE". 

NOTE 3: If a variable, other than the default SimFlex™ variables, is used and it is not defined as an 

environment variable, it will be translated as "UNDEFINED". 

NOTE 4: The variable %TSCRIPT_STATUS% may have different values in the title/header and in the 

footer. The former will be the status of the script *before* running the script (i.e. the former status 

of the script), whereas the later will be the status of the script after running it. 

This is a list of the default SimFlex™ variables available: 

SimFlex™ variables 

%FILENAME% %DEVICE_VENDOR% %TESTLAB_POSTALCODE% 

%DATE% %DEVICE_VERSION% %TESTLAB_CITY% 

%TIME% %DEVICE_COMMENTS% %TESTLAB_COUNTRY% 

%TOOL_NAME% %DEVICE_IPADDRESS% %TESTLAB_CTWORKPLACE% 

%TOOL_VERSION% %DEVICE_SCLFILE% %CUSTOMER_COMPANY% 

%TESTER% %SESSION_NAME% %CUSTOMER_STREET% 
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%TESTBENCH% %SESSION_ORDERNR% %CUSTOMER_HOUSENUMBER% 

%TSUITE_NAME% %SESSION_SETUP% %CUSTOMER_POSTALCODE% 

%TSUITE_VERSION% %SESSION_VERSION% %CUSTOMER_CITY% 

%TSCRIPT_NAME% %SESSION_COMMENTS% %CUSTOMER_COUNTRY% 

%TSCRIPT_VERSION% %TESTLAB_COMPANY% %CUSTOMER_CTWORKPLACE% 

%TSCRIPT_STATUS% %TESTLAB_STREET%  

%DEVICE_NAME% %TESTLAB_HOUSENUMBER  

 

6.5.2 Test Lab information 

Every time a test session is created the Test Lab information must be entered. The default Test Lab 

information can be modified by opening and editing an xml file under the ‘Application base directory’ 

folder in ‘.\TestLab\TestLab.xml’  

 

Figure 6-13 TestLab.xml 

Introduce the company’s details under the Company, Street, HouseNumber, PostalCode, City, Country 

and ConfTestingWorkplace attributes. 

Every new session created will include the modified information by default. 

6.5.3 Vendor information 

As with the Test Lab information, every time a test session is created the Vendor information must 

be entered. Once a vendor has been introduced in the session’s folder (by creating the first session 

for a device from that vendor) an xml file will be created under the ‘Application base directory’ folder 

in .\Sessions\%VENDOR%\Vendor.xml’. 
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Figure 6-14 Vendor.xml 

Introduce the vendor’s details under the Company, Street, HouseNumber, PostalCode, City, Country 

and ConfTestingWorkplace attributes. 

Every new session created for one of that vendor’s devices will include the modified information by 

default. 
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7 ConsoleCS Setup 
SimFlex Client Simulator Edition 2 has option to work in Console mode. In order to perform 

initialization, User has to open Command prompt application Cmd.exe with administrative rights. 

Next, allocate ConsoleCS application with name SimFlex.IEC61850.ConsoleCS.exe in folder 

“C:\Program Files (x86)\GridClone\SimFlex Client Simulator Ed2\”. And run it with 

following command: 

C:\Program Files (x86)\GridClone\SimFlex Client Simulator Ed2> 

SimFlex.IEC61850.ConsoleCS.exe -test -p "C:\File Location\Preconfigured Test Suite.suite" -

d DeviceName -g 1 -r "C:\Folder Location for results" 

 

Detail explanation of command flags used: 

-test : start testing, no parameters 

-p : Enter location of preconfigured Test Suite for testing 

-d : Enter the name of device that will be tested and defined in Device Tab in GUI and  

stored in "C:\ProgramData\GridClone\SimFlexEd2\TestLab\Devices\Devices.xml" file 

-g : Enter number 1, 2 or 3 for GOOSE subscription as defined in GOOSE Subscription 

tabs 

-r : Enter location of desired folder that test results will be stored at 

 

By typing following command, User will get command syntax and example similar as above: 

C:\Program Files (x86)\GridClone\SimFlex Client Simulator Ed2> 

SimFlex.IEC61850.ConsoleCS.exe -help TEST 

Command can be executed by adding full path in the Command Prompt, Test Manager etc. For 

example: 

C:\Program Files (x86)\GridClone\SimFlex Client Simulator 

Ed2\SimFlex.IEC61850.ConsoleCS.exe -test -p 

"C:\ProgramData\GridClone\SimFlexEd2\TestLab\TestSuites\IEC 61850 Ed.2 Conformance 

Test.suite" -d DeviceName -g 1 -r 

"C:\ProgramData\GridClone\SimFlexEd2\TestLab\TestBenches\TESTBENCH_0\Result" 

or path can be added to Environment Variables and then used as a command, for example: 

C:> SimFlex.IEC61850.ConsoleCS.exe -test -p 

"C:\ProgramData\GridClone\SimFlexEd2\TestLab\TestSuites\IEC 61850 Ed.2 Conformance 

Test.suite" -d DeviceName -g 1 -r 

"C:\ProgramData\GridClone\SimFlexEd2\TestLab\TestBenches\TESTBENCH_0\Result" 
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NOTE 1: In Predefined Test Suite: 

- Mark which test blocks (conformance blocks) and which tests are to be executed 

- Tests that are to be automatically executed should not require manual operations (such as 

manual verification of results, manual confirmations etc.) 

 

NOTE 2: All setting from: 

- General tab 

- Devices tab 

- NIC tab 

- GOOSE tab 

Should be set through GUI interface once and will be reused by ConsoleCS application. 

Every new session created for one of vendor’s devices will include the modified information by 

default. 
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8 Frequently Asked Questions (FAQ) 
Some questions do reoccur and become frequently asked (that is, more than once). Check this 

section before you contact GridClone for support on your question. 

8.1 General 

8.1.1 How to install the SimFlex™ Client Simulator? 

Read the Getting started document that comes with the program for a detailed description of the 

installation procedure. If you do not have administrator rights on your PC, please contact your IT 

department. 

8.1.2 How can I check if my device is available on the network? 

See that your DUT is turned on and connected to the same LAN as your SimFlexTM IEC 61850 Client 

Simulator . Find out the IP address of the DUT. 

A simple test to check if the DUT is connected and within range of the SimFlexTM IEC 61850 Client 

Simulator is to open a Windows Command Window (cmd.exe) and typing the following instruction at 

the caret: 

 

Figure 8-1 Ping command 

The IP address behind the ping command shall be the IP address of the DUT. In case the DUT is visible 

it will react with positive responds. 

Next, be sure that you selected the appropriate network interface in the [ General ] and [ NIC ] tabs 

in the Configuration Dialog of the SimFlexTM IEC 61850 Client Simulator . 

After that be sure that you created a DUT in the [ Devices ] tab in the Configuration Dialog of the 

SimFlexTM IEC 61850 Client Simulator . Check if the IP address is the same as the IP address of your 

DUT. 

Try to retrieve the date model of the DUT. 
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8.1.3 The Client Simulator does not start or complains about the license 

In the system tray check if the CodeMeter service is running (clicking on the small system-tray 

arrow). 

If the CodeMeter is not visible, it could be that it is not running, or that the service *is* running, but 

the CodeMeter program is not visible. 

a) In the first case: re-install the SimFlexTM IEC 61850 Client Simulator and make sure the WIBU 
software installs correctly. 

b) In the second case: press Windows Start button and locate the CodeMeter installation. Then 
start the “CodeMeter Control Center” manually. 

Once the CodeMeter Control Center is started, open it (from the system tray) and check that there is 

a license shown in the left part of the dialog. Make sure you have inserted the USB license key in one 

of the available USB ports! 

In case you are running a trial version of the SimFlexTM IEC 61850 Client Simulator : 

If there is no license shown, select File→Import License from the menu and locate the “*.lic” 

file in the Client Simulator folder (In the folder where you installed the program, e.g. 

C:\Program Files\GridClone\...). Note that the CodeMeter Control Center might have a filter 

like “*.WibuCmRaU”. Change it to “*.*” or “*.lic” to make the license file visible. 

Once the license file has been selected and opened it should be visible in the CodeMeter 

Control Center. 

To be sure the license is activated: stop and start the CodeMeter Control Center service by 

pressing Process→Stop CodeMeter Service and then Process→Start CodeMeter Service. 

Finally re-start the Client Simulator. If the problem persists please contact GridClone for support. 

8.1.4 Missing Module ‘OS’ 

After the installation of the SimFlexTM IEC 61850 Client Simulator, one of the first actions that a user 

does is creating the global variables. This is done by enabling in the test suite the group “0. 

Configuration” and the script “Create Global Variables”. See the excerpt of the test suite below. 

 

Figure 8-2 Test Suite Configuration Block 

In some cases, the following error might occur when the global variables are being created: 
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Figure 8-3 No Module names os notification 

The reason can be that IronPython was not installed in its default location. 

Solution: add the following environment variable (a system variable, not a user variable) in Windows 

and retry to create the global variables in the SimFlex™ Client Simulator (restart of the program first). 

Set SimflexIpyLib=<path to IronPython lib folder> 

Example: 

Set SimflexIpyLib=C:\Program Files (x86)\IronPython 2.7.1\Lib 

8.2 Test suites 

8.2.1 How to copy a test suite from a session? 

Read also: 

• Part 4.1 ‘Open a test suite’ 

• Part 5.6 ‘Modify and copy test sessions’. 

Note that test sessions created with SimFlex™ CS Edition 1 cannot be loaded with SimFlex™ CS 

Edition 2 due to differences in model and test structures. 

The test suite can be found in one of the following places, depending on the use of the suite. 

‘Used outside of a session’: 

%APPLICATION_BASE%\TestLab\TestSuites\*.session 

The test suite is not bound to a test session and is (most likely) not configured. It can be used as a 

base suite to construct a test session. 

NOTE: Initially the folder “%APPLICATION_BASE%\TestLab\TestSuites” might not contain the IEC 

61850 Edition 2 test suite. In that case the test suite is located in the installation folder of the SimFlex 

CS, e.g. “C:\Program Files (x86)\GridClone\SimFlex Client Simulator\Testsuites” (32bit 

version of Windows) or “C:\Program Files (x86)\GridClone\SimFlex Client 

Simulator\Testsuites” (64bits version of Windows) for the default installation of the program. 

‘Used in a session’: 

%APPLICATION_BASE%\Session\%VENDOR%\%DEVICE%[.%TEST_NR%]\TestSuites\*.tsf 

The test suite is bound to a test session, the details are in the .tsf file, including all scripts and 

configuration details. 
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The preferred way for copying sessions is through the Test session settings form and changing the 

field [Test order number] (See 5.6 ‘Modify and copy test sessions’). It can be copied to another 

session area and used ‘as is’. 

%APPLICATION_BASE% = ‘C:\ProgramData\GridClone\SimFlex’ 

By default. It can be changed in the configuration (see Edit → Settings, tab [ General ] field 

‘Application base directory’ for the actual setting). 

%VENDOR%, %DEVICE% and %TEST_NR% is data from the actual session referring to.  

The %TEST_NR% is optional. 
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9 Additional Information 
In this section you will find information on additional topics. 

9.1 File name conventions 

Any *.txt file is a test result file and has the same content as the log frame. 

Any *.log file is an error log file for errors related to the program and not to the test. 

sAss1-2013-01-27_09.01.02-CS.txt is the test result of test case sAss1 generated by the Client 

Simulator on January 27th, 2013 at 09:01 (local time). 

2013-01-07_09.28.43-SimFlexError.log is an error log for the same run. This file is located in the 

“Application base directory”. 

9.2 Used abbreviations 

CS Client Simulator 

DUT Device Under Test. 

IEC The International Electrotechnical Commission, managing international standards. See: 

http://www.iec.ch/ 

IEC 61850 The IEC 61850:2007 standard, revision A and B 

IED Intelligent Electronic Device 

UCA The UCA® International Users Group. See: http://www.ucaiug.org 

9.3 Referenced documents 

IEC 61850 IEC 61850:2007 revision A and B 

MMS ISO 9506:2003 (as used by IEC 61850-8) 

 Getting started.pdf 

9.4 Referenced tools 

WinPcap For capturing network traffic, see: http://www.winpcap.org/ 

WireShark For analyzing network traffic, see: http://www.wireshark.org/ 

http://www.iec.ch/
http://www.ucaiug.org/default.aspx
http://www.winpcap.org/
http://www.wireshark.org/
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10 Document Version History 
 

The table below describes the version history of this document. 

Version Date By Subject 

1.0 April 15, 2013 EM Initial version 

1.1 June 19, 2013 EM General update before release. 

1.2 December 16, 2013 WvE SimFlex™ Protocol Analyzer integrated 

1.3 May 20, 2019 CV Update 
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